You are here: Home / Members / LordemannD's Home / disable the join feature

disable the join feature

Dave,

I found this from Aug 11:

=A0Michael,
I used the technique that Jonathan pointed at.

Now to log-in you must go directly to the log-in form
=A0 =A0"<a href=3D"http://schuh.homelinux.com:8081/Main/login_form"= target=3D"_blank">http://schuh.homelinux.com:8081/Main/login_form</a>&quo= t;<br> <br> It just hides the log-in and register. I suspect that a knowledgeable atta= cker<br> could still find the registration form and attempt to register.<br> <br> But it is a place to start. Any one else that is working on it will have= to be informed about<br> the change.<br> <br> For the moment we will just rely on browser closing to destroy the log-in= session.<br> Or you can<br> =A0 =A0 =A0 =A0&quot;<a href=3D"http://schuh.homelinux.com:8081/Main/logo= ut" target=3D"_blank">http://schuh.homelinux.com:8081/Main/logout</a>&quot= ;<br> <br> To have someone register for an account:<br> =A0 =A0 =A0 =A0&quot;<a href=3D"http://schuh.homelinux.com:8081/Main/join= _form" target=3D"_blank">http://schuh.homelinux.com:8081/Main/join_form</a= >&quot;<br> <br> But it doesn&#39;t work at the moment, it probably sends an email message<= br> an email address that isn&#39;t correct or isn&#39;t set.<br><font color= =3D"#888888"> -Dave</font></div><br>It would be good to add this to my notes page at the= root level of LAR.org.=A0 I will try and do this later if you don&#39;t= do it before then.=A0 I am working on getting back to productivity at NAS= A so I don&#39;t want to spend much time on this now.<br> <br>As for the member directories, they have appeared to disappear.=A0 I= don&#39;t know why or exactly when this happened.=A0 I don&#39;t know if= it is related to your changes or not.=A0 <br><br>BTW, email is not set up= on the website so anything that uses that will fail.<br> <br>Accounts are made at two levels: <br><ul><li><a href=3D"http://www.los= altosrobotics.org:8080/Main/acl_users/source_users/manage_workspace">http:= //www.losaltosrobotics.org:8080/Main/acl_users/source_users/manage_workspa= ce</a></li> <li><a href=3D"http://www.losaltosrobotics.org:8080/acl_users/users/manage= _users">http://www.losaltosrobotics.org:8080/acl_users/users/manage_users<= /a></li></ul>The first is for the &quot;Main&quot; website (in this case= LAR), and the second is for the entire plone installation.=A0 Sally&#39;s= account was created at the second one.=A0 I could not get her account to= have edit permissions from the first.=A0 I spent over an hour getting her= account working this morning.=A0 Fortunately I was on EST and had time to= do so before work.=A0 I certainly want to help people that want to contri= bute so I spent the time to make her account work.<br> <br>The account stuff is partially written up on <a href=3D"http://www.los= altosrobotics.org:8080/Main/PloneNotes">http://www.losaltosrobotics.org:80= 80/Main/PloneNotes</a> .=A0 Feel free to update and add to this file.=A0= The account writeup is somewhat correct.=A0 I want to go back and add to= it sometime.<br> <br>Thanks again for helping out!<br><br>Regards,<br>=A0=A0 Michael<br><br= ><div class=3D"gmail_quote">On Wed, Oct 20, 2010 at 10:36 AM, Dave Lordema= nn <span dir=3D"ltr">&lt;<a href=3D"mailto:LordemannD@aol.com">LordemannD@= aol.com</a>&gt;</span> wrote:<br> <blockquote class=3D"gmail_quote" style=3D"margin: 0pt 0pt 0pt 0.8ex; bord= er-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">Hi Michael,<br> <br> I see a little strangeness and just want to check with you.<br> <br> I logged in as sally, it worked fine.<br> But then I looked in the Members directory and didn&#39;t find her.<br> (using the manage interface)<br> <br> Now I notice that the private directories for the Member don&#39;t show up= <br> when you login. They are still there, but harder to get to. I don&#39;t th= ink this is a problem,<br> I don&#39;t believe any recent activity has gone on in the Member director= ies.<br> No Member directory was created for sally.<br> <br> But it is a change that I didn&#39;t expect. Is this something that you di= d or<br> is it an unintended consequence of hiding the login and join pages?<br> <br> Since we don&#39;t really use the plone model of creating content in priva= te directories and then<br> publishing it, this is probably a don&#39;t care.<br> <br> When I turned off the login and join I had intended to prepare instruction= s<br> on how to re-enable it. And how to do the login/logout/password change.<br= > Did I send it in a message to you?<br> <br> I will try and re-learn about this in the next few days.<br><font color=3D= "#888888"> -Dave<br> </font></blockquote></div><br>

Document Actions